Rattle Noise after installing Header

Miata Parts, Intakes, Superchargers, Headers, Exhausts, Shocks, Springs, Sway Bars, Brake Kits, Autocross and track mods.

Rattle Noise after installing Header

Postby ManishS409 » Fri Apr 25, 2014 6:02 am

I just recently installed the GWR ceramic street header. Before this install, I already had the GWR midpipe and Q muffler and also MS CAI. I did not have any rattles until after I installed the header.

The noise is not very loud. I can't hear it during idle. Only momentarily when I blip the throttle. It only happens during engaging the clutch on first gear. After that I don't hear it. I hear it the most in parking lots where I am going slow and probably engaging the clutch a few times.

I would describe the sound similar to that of a diesel. Almost sounds like a rattle in the engine. Of course it is not that loud and only occurs for a moment when I engage the clutch.

The fact that I didn't have the noise before makes me think that it's not the midpipe or exhaust? I'm not sure what part of the header it could be. There are only two connection points. One to the engine and one to the midpipe. I'm pretty sure I torqued these to the proper settings. I looked under the car and the exhaust doesn't appear to be touching anything. I suppose I can tighten things up to see what happens.

I do notice the noise less when the car is cold. It seems the noise is more prevalent once the car is warmed up. Is it possible that there is something going on with the cat in the street header?

Does anyone have any ideas?

Kan-O-Z
ManishS409
 
Posts: 4
Joined: Wed Mar 20, 2013 6:30 pm

Re: Rattle Noise after installing Header

Postby Brian » Fri Apr 25, 2014 6:17 am

My guess is that midpipe with slip joint is adjusted slightly long and is hitting brace under the car. Try playing with Midpipe length, making it shorter so it hangs higher under the car.
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
Brian
Site Admin
 
Posts: 7851
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA

Re: Rattle Noise after installing Header

Postby ManishS409 » Fri Apr 25, 2014 7:32 am

I did install 2 IL braces at the same time I did this install. They are the same 2 braces as on your PRHT street car.
I tried completely removing the bigger one (not X) that is close to header/midpipe connection since that one seems close to the midpipe. That didn't help. The X brace seems like it has good distance from the midpipe.

I read something about a heat shield near the O2 sensor. Could that be vibrating? I only hear it during engaging the clutch. Hoping its something little...
ManishS409
 
Posts: 4
Joined: Wed Mar 20, 2013 6:30 pm

Re: Rattle Noise after installing Header

Postby Brian » Fri Apr 25, 2014 11:02 am

Ah...my bet is still midpipe on new braces...might need to add washers to space them lower if you can't get mid pipe shorter. Yes...The shield on first o2 can rattle but higher pitch 'tink tink' usually.
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
Brian
Site Admin
 
Posts: 7851
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA

Re: Rattle Noise after installing Header

Postby GaryO935 » Sat Apr 26, 2014 3:27 am

My X brace had a metal tag that was riveted on...not very tightly ...it can rattle. If you drill out the rivets, then you will have bits inside the X brace.......but if you pound the rivet heads so they tighten all the way. Also check that the sensor leads/connectors aren't rattling against something....and of course try the things Brian suggested.
GaryO935
 
Posts: 10
Joined: Sat Feb 16, 2013 5:39 pm

Re: Rattle Noise after installing Header

Postby LiquidSilverNC » Thu May 01, 2014 11:22 am

This probably isn't the case, I had a noticeable rattle after the header install as well. Turns out I forgot to remove the little bracket the secures the OEM header. The part that connects to the cat.
LiquidSilverNC
 
Posts: 11
Joined: Thu Mar 06, 2014 10:27 am


Return to Mazda Miata and Fiat 124

Who is online

Users browsing this forum: Bing [Bot] and 9 guests