Clunk After Rear Sway Bar Install

Mazda 2, Mazda 3 and 6 Parts and Performance from Intakes to Headers, Exhaust, Shocks, Springs, Sway Bars, Brake Kits... it's all there.

Clunk After Rear Sway Bar Install

Postby MarkT193 » Thu Sep 28, 2017 1:12 pm

Hello fellow enthusiasts. I have 2014 Mazda 6 GT. I currently have Tanabe lowering springs installed as well as a aftermarket rear sway with torsion boxes and upgraded Moog links. I had the shop install the bar at the stiffest setting. After leaving the shop and driving home had zero issues. I got into town and headed to a friends house that happens to have a super steep driveway. You have to pull in at a angle or risk ripping your bumper off. As I started in the driveway and the rear of the car articulated heavily I heard this heavy CLUNK!!. It has done it a few more times again going into various entrances that are very steep. Still no issues over regular bumpy roads. I did get under the car and try and look, but found nothing that indicated the bar hitting the sub-frame or something with the links. Could it be the bushings? Is it settling out? Everything seems tight and secure as far as nuts and bolts. Does anyone on here have any input as to what might be the cause? Any help is greatly appreciated.
MarkT193
 
Posts: 1
Joined: Tue Sep 26, 2017 4:16 pm

Re: Clunk After Rear Sway Bar Install

Postby Brian » Thu Sep 28, 2017 1:25 pm

Sway bar bushings can get dry and stick...and release with sudden CLUNK.

Can also be issue with the endlinks, installed wrong side of bar or sticking. Have a mechanic inspect.
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
Brian
Site Admin
 
Posts: 7798
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA


Return to Mazda 2, Mazda 3 and 6

Who is online

Users browsing this forum: No registered users and 1 guest