Possible Immobilizer System problem?

Miata Parts, Intakes, Superchargers, Headers, Exhausts, Shocks, Springs, Sway Bars, Brake Kits, Autocross and track mods.

Possible Immobilizer System problem?

Postby CHeavin_2006 » Wed Jun 01, 2011 3:51 pm

I just installed the RS header over the weekend. After about 10 minutes of driving my engine just cuts out and I flip it into neutral and pull over on a side street. I try to start it up and nothing. The battery is fine. I have the advanced key system and I'm almost sure it's the immobilizer system. I've looked through the manual and it seems like that is the problem. I'm still able to unlock the doors with the key-less entry, but when I turn the key into the on position the little light in the dash with the car and the key inside flash quickly. I figured I check on the forum to see if anybody has had this problem or has a possible solution before I have to talk to the guys at Mazda.

Thanks,
Cory
CHeavin_2006
 
Posts: 80
Joined: Sun Jan 24, 2010 4:29 pm

Re: Possible Immobilizer System problem?

Postby jasonMX5 » Wed Jun 01, 2011 4:50 pm

It could be, if so it has to be towed to the dealer. But before you call make sure to go into the fuse box and check all the engine fuses, then the drivers door fuse box as well has one. If a fuse is blown the key will flicker like that I've had that happen.

Also if you installed the extension cables and a fuse is blown go take a look at the cables. I had a situation where one of my cables was caught somehow near the suspension components and chaffed until it hit bare wire. Then it touched metal and shorted, causing a fuse to blow and the engine died just like yours did. That ended up with me being pushed back to my house by the police. :) hehehe.
2007 NC, 6spd. True Red, BEGi turbocharged. Supporting mods.
jasonMX5
 
Posts: 69
Joined: Thu Feb 28, 2008 9:10 am
Location: Sterling VA

Re: Possible Immobilizer System problem?

Postby jboemler » Wed Jun 01, 2011 4:59 pm

I doubt the immobilizer is the problem. The way the system works, it only checks when the key is first turned.
jboemler
 
Posts: 273
Joined: Fri Oct 10, 2008 6:15 pm
Location: Mukilteo WA

Re: Possible Immobilizer System problem?

Postby Brian » Wed Jun 01, 2011 9:17 pm

My guess is that you missed that part of the forum installation directions about being really careful with the plastic plugs for the O2 sensors....and they were allowed to melt and short....which WILL stop the car FAST. Find the shorted fuse, replace. Check those O2 wires and plugs and if melted, repair them.
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
Brian
Site Admin
 
Posts: 8148
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA


Return to Mazda Miata and Fiat 124

Who is online

Users browsing this forum: Google [Bot] and 2 guests