P0137

Miata Parts, Intakes, Superchargers, Headers, Exhausts, Shocks, Springs, Sway Bars, Brake Kits, Autocross and track mods.
Post Reply
ScottMulholland
Posts: 8
Joined: Sat Feb 27, 2016 8:43 pm

P0137

Post by ScottMulholland »

Three weeks ago I installed the max power header,Helmholtz mid pipe and O2 extensions along with a Roadstersport 2 that I already had on my 2014 Club Edition. Install went great and I love the results. But after about 250 - 300 miles I got a P0137 code. Is this common and should I be worried. If anyone knows what I need to do to fix that would be great. I would like to get a Moto East tune but when I purchased the car I bought the extended warranty and I don't really want to completely void that just yet.
Brian
Site Admin
Posts: 10549
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA
Contact:

Re: P0137

Post by Brian »

Never seen that code on install here, but my quick Google search says low voltage on rear sensor. So, I would start by checking wires into that rear sensor, make sure they are NOT pinched over at hard angle. Perhaps unplug and replug the extension cables to make sure good connections on those (and LOOK into the plugs and make sure pins are not yanked too far back in the plug, which can happen if during install the extension gets yanked on too hard).
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
ScottMulholland
Posts: 8
Joined: Sat Feb 27, 2016 8:43 pm

Re: P0137

Post by ScottMulholland »

Thank you for the response I will check connections tomorrow but might not be able to get to road test it for a few more days or maybe a week we're supposed to get 5 inches of snow tonight.
Post Reply