P0421

Miata Parts, Intakes, Superchargers, Headers, Exhausts, Shocks, Springs, Sway Bars, Brake Kits, Autocross and track mods.
Post Reply
AlbertoC215
Posts: 3
Joined: Wed Feb 06, 2019 5:19 pm

P0421

Post by AlbertoC215 »

Hi there,
I was getting this code (P0421) on my 2015 club with 39,000 miles. It has a RoadsterSport All Stainless Steel MX5 COMPLETE STREET EXHAUST COMBO...with CERAMIC installed @ 18,000 miles. I replaced both sensors with OEM parts and it was okay for 10 days. Today the "magic" light turns on again... It's no way the catalytic is bad... it's only 20,000 miles old???
Any clue?
Attachments
P0421.png
P0421.png (169.6 KiB) Viewed 6937 times
Brian
Site Admin
Posts: 11465
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA
Contact:

Re: P0421

Post by Brian »

Likely a sensor connection. Look at the pins in the plugs for the O2 sensors, are all the pins flush or did one get pushed deep inside the plug?
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
AlbertoC215
Posts: 3
Joined: Wed Feb 06, 2019 5:19 pm

Re: P0421

Post by AlbertoC215 »

Thanks Brian, I will check the connector...
Al
AlbertoC215
Posts: 3
Joined: Wed Feb 06, 2019 5:19 pm

Re: P0421

Post by AlbertoC215 »

Hi Brian,
This weekend I could check the plugs..., they were fine. Then I cleared the code. But after running a few miles the engine light turns on again, same code... Any idea?
Let me know. Thanks.
Al
Ryan @ GWR
Posts: 502
Joined: Fri Oct 17, 2014 11:37 pm

Re: P0421

Post by Ryan @ GWR »

Hi Al,

The code will keep coming back until you find the actual cause of the issue.
Check the wiring as well. Sometimes a zip tie comes loose or similar and the wire gets melted against the exhaust.
If all the wiring for the sensor is good, the connector is good, and you've replaced the o2 sensors, then the cat itself is the next suspect.
Get in touch with us by email and we can help further.
Post Reply