My Edelbrock has lag below 3000 rpm

Miata Parts, Intakes, Superchargers, Headers, Exhausts, Shocks, Springs, Sway Bars, Brake Kits, Autocross and track mods.

My Edelbrock has lag below 3000 rpm

Postby PsychoMX5 » Sun Jul 15, 2018 8:47 pm

My Edelbrock supercharger is installed, and the car runs fairly smoothly. However, there is a noticeable lag below about 3000 rpm. See attached dyno graph which shows torque is lower than stock below 3000 rpm. There is also a very slight throttle surge when lifting off the accelerator.

I've taken some data logs; one is linked here https://datazap.me/u/psycho/3-cropped?log=0&data=2-17

The log shows KR is 0 up to 2600 rpm, then quickly increases to a max of -1.62 at 2879 rpm, then decreases to 0 by 5700 rpm. I thought it might be an issue with the bypass valve, but I got underneath with a borescope and confirmed none of the hoses are kinked or crushed. Any ideas what the problem might be?
Attachments
datazap-chart.png
Dyno before-after.JPG
2016 Club MT, Edelbrock SC, RS Super Q TTSS, Progress Springs, 17x8 6UL w/Yokohama S.drive 235/40-17
PsychoMX5
 
Posts: 2
Joined: Fri Jul 13, 2018 3:00 pm

Re: My Edelbrock has lag below 3000 rpm

Postby Brian » Mon Jul 16, 2018 5:40 am

My wife's RF on stock header and CARB tune for comparison. Not sure why yours is slow to ramp up by comparison but I would look at bypass valve first. Had a few folks hit the bypass valve during install with result the arm attached to it was bent or broken.
Attachments
Carb-Header.jpg
Carb-Header.jpg (148.34 KiB)
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
Brian
Site Admin
 
Posts: 8360
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA

Re: My Edelbrock has lag below 3000 rpm

Postby PsychoMX5 » Wed Aug 15, 2018 5:44 pm

Here's an update in case you're not following on miata.net: the Fab9 calibration solved the low-rpm hesitation issue. Bryan at Fab9 has been great...he was able to fix the low-rpm performance and other side effects like cruise control not keeping speed and idle droop with AC on. If anyone is still dealing with subpar Edelbrock performance, look up Fab9!
2016 Club MT, Edelbrock SC, RS Super Q TTSS, Progress Springs, 17x8 6UL w/Yokohama S.drive 235/40-17
PsychoMX5
 
Posts: 2
Joined: Fri Jul 13, 2018 3:00 pm

Re: My Edelbrock has lag below 3000 rpm

Postby MarkA102 » Sat Aug 25, 2018 4:52 pm

I'll second this regarding the FAB9 tune. On my car (2016 GT AT) EB V3 would surge when the accelerator was let off. Cruise control was unusable up to around 45 mph with bucking, over 45 when it was engaged it clamped the throttle at 21% resulting in speed loss. Brian fixed all of this with a tune except the throttle clamp at 21%, shortly after reporting this to him he had that fixed. I received the EB V4 tune this last week and it is much better but still had the surge when letting off the accelerator. Went back to FAB9 tune and everything fixed. Waiting on FAB9 to dyno their car to see the performance using their tune.
MarkA102
 
Posts: 2
Joined: Sun Apr 22, 2018 9:41 pm


Return to Mazda Miata and Fiat 124

Who is online

Users browsing this forum: No registered users and 8 guests