Squeak from NC rear suspension after install

Installations instructions for MonsterFlow intakes, Big Brake Kits, shocks and more.
Post Reply
jdaniels509
Posts: 11
Joined: Fri Apr 10, 2009 8:20 pm
Location: South Jersey

Squeak from NC rear suspension after install

Post by jdaniels509 »

2006 NC GT 6sp. Installed Progress/koni sport about a year ago. Put maybe 2000 miles on it since then. Love the way it drives and rides, BUT, I get a loud squeak from the rear suspension when hitting sharp bumps or dips. Both sides do it, sort of sounds like it's coming from the top of the shock or the mount. Again, it's infrequent, seems like rapid and/or deep compression of the rear suspension causes a loud, brief squeak. Ideas?
06 GT 6M
Formerly: 95 B&T Miata
Brian
Site Admin
Posts: 11278
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA
Contact:

Re: Squeak from NC rear suspension after install

Post by Brian »

Could be several things. Did sways at same time or just shocks and springs? Assuming just shocks and springs I would put a wrench on things back there and make sure top and bottom shock mounting bolts are snug. If you did sways too, lube up the bushings again.
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
jdaniels509
Posts: 11
Joined: Fri Apr 10, 2009 8:20 pm
Location: South Jersey

Re: Squeak from NC rear suspension after install

Post by jdaniels509 »

Yeah, sways too. Can I lube them with the sway installed?
06 GT 6M
Formerly: 95 B&T Miata
Brian
Site Admin
Posts: 11278
Joined: Tue Feb 15, 2005 11:44 am
Location: San Diego CA
Contact:

Re: Squeak from NC rear suspension after install

Post by Brian »

Usually can get that done with bars installed. Put a smear of fresh lube against the poly bushings both sides of the D clip. I have a bottle with white lithium spray and maybe once a year just a quick shot seems to do it both sides as shown with the red arrows here. I found this picture on one of the forums and added the red arrows, but notice the nut is loose in this picture and good opportunity to make sure nothing has come loose.
Attachments
RearSwayLube.jpg
RearSwayLube.jpg (59 KiB) Viewed 3123 times
Brian Goodwin
Good-Win Racing
www.good-win-racing.com
jdaniels509
Posts: 11
Joined: Fri Apr 10, 2009 8:20 pm
Location: South Jersey

Re: Squeak from NC rear suspension after install

Post by jdaniels509 »

Ok, great, thanks, I'll give that a shot. Ooo, yeah, that loose nut on the sway bracket in the picture. Wonder if he backed that off a little thinking it would help allow the grease to get in there? Ill just hit both sides of both bushings with some white lithium as you suggest and go from there.
06 GT 6M
Formerly: 95 B&T Miata
Post Reply